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Sinopsis singkat: 
 

Apakah Anda tahu bagaimana cara membuat garis panjang hanya dengan memberi ketukan tiga kali pada 
keyboard? Apakah Anda sadar bahwa selama ini Anda adalah orang yang boros kertas dan ingin menghemat? 
Apakah Anda bisa menghitung rumus matematika super-rumit langsung menggunakan MS Word 2003? Jika 

Anda tidak tahu jawaban dari pertanyaan-pertanyaan di atas, maka itu belumlah seberapa sebab masih ada 98 
pertanyaan lagi yang harus Anda cari tahu jawabannya! 

Buku ini memang unik sebab menggali sisi-sisi MS Word 2003 yang jarang sekali disentuh, diperhatikan, 
apalagi dimanfaatkan. Padahal, jika Anda tahu semua rahasianya, Anda akan menjadi seorang penulis yang 
serba efisien dan praktis.  Cobalah baca buku ini sebab buku ini menawarkan kejutan yang akan membuat 

Anda tahu sepenuhnya rahasia ratusan hal yang tersimpan di dalam program MS Word 2003.  
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2 
Meletakkan Gambar 

 
 

 

 

 

 

3  

Cepat Memasukkan Gambar 
 
Saat Anda membuat laporan untuk riset atau peneltian, 
biasanya Anda akan meletakkan sebuah logo perusahaan atau 
universitas dan koleksi gambar-gambar lain dalam dokumen 
Anda. Pada intinya, memasukkan gambar menggunakan MS 
Word 2003 tidaklah sulit.  

Tapi, bagaimana caranya supaya kita dapat memasukkan 
gambar secara cepat tanpa harus bermain–main dengan 
kotak dilaog? Apabila Anda tidak mau ambil pusing dengan 
kotak dialog, maka tip ini penting untuk Anda cermati. 

Caranya adalah, pertama-tama carilah ruang kosong dalam 
dokumen Anda sebagai tempat untuk penempatan gambar. 
Kalau sudah, klik menu Insert > Picture > From File. Setelah 
itu, kotak dialog From File akan terbuka dan carilah gambar 
yang akan Anda masukan ke dalam dokumen. Kalau gambar 
itu sudah ditemukan, tekanlah tombol Insert. Dalam sekejap, 
gambar akan masuk ke dalam dokumen Anda. 
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Gambar 2.1. Insert Picture 

Setelah gambar tadi melekat di dalam dokumen, klik gambar 
tersebut untuk memilihnya. Sekarang, klik menu Insert > 
AutoText > AutoText. Dalam waktu singkat akan muncul 
kotak dialog Auto Correct.  

Pilihlah tab AutoText. Pada bagian Enter AutoText Entries 
here, masukkan sebuah teks yang unik. Misalnya, Anda dapat 
mengetikkan teks ‘logo’ ke dalam kotak itu. Kalau sudah, 
tekan tombol Add. 

 

Gambar 2.2. Jendela AutoText 
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Kini, Anda telah memiliki perintah untuk memasukkan 
gambar secara lebih cepat ke dalam dokumen Anda sendiri.  

Setiap kali Anda ingin memasukkan gambar menggunakan 
AutoText tersebut, lakukan langkah berikut. Klik Insert > 
AutoText dan carilah option ‘Logo’ di tempat itu. Biasanya, 
ia diletakkan di sebuah folder khusus dalam menu AutoText. 

  

Gambar 2.3. Memasukkan Gambar atau Logo 
Menggunakan AutoText 

4  

Mengolah Gambar 
 
Di mata orang awam, MS Word 2003 dipersepsikan sebagai 
program yang tugasnya hanya untuk mengolah kata saja. 
Padahal, fungsi MS Word 2003 tidak hanya itu. Ia juga dapat 
difungsikan untuk mengolah gambar, seperti mengatur 
ukuran gambar, mengatur skala, mengatur terang gelapnya 
sebuah gambar, dan memotong gambar. 

Untuk mengatur skala gambar, klik gambar tersebut sampai 
muncul handle (kotak-kotak kecil) berwarna hitam yang 
fungsinya untuk mengubah ukuran sebuah gambar. Handle 
itu sendiri terdapat di setiap sisi seluruh gambar. Seret kotak 
hitam itu ke kanan-kiri-atas-bawah sampai Anda mendapat-
kan ukuran gambar yang lebih pas. 
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Gambar 2.4. Gambar yang Telah Dikelilingi Kotak-kotak 
Hitam (Handle) yang Dapat Anda Seret ke Segala Arah 

Untuk memotong gambar, klik ikon Crop terlebih dulu. Jika 
ikon tersebut tidak ada, munculkanlah terlebih dulu dengan 
mengklik menu View > Toolbar > Picture. Dalam sekejap, 
toolbar Picture akan muncul.  

Sekarang, klik ikon Crop. Teknik memotong gambar sama 
seperti teknik mengubah ukuran gambar. Anda tinggal 
menggeser-geser handle ke kanan-kiri-atas-bawah. 

 

Gambar 2.5. Ikon Crop dalam Toolbar Picture 

Sedangkan untuk mengatur terang gelapnya gambar, klik 
ikon More Contrast atau More Brightness yang ada di 
toolbar Picture itu. Ikon ini memiliki simbol berwujud 
lingkaran dengan anak panah di sampingnya.  

Untuk menambah nilai Contrast atau Brightness, klik ikon 
More Contrast atau More Brightness berkali-kali. Begitu pula 
sebaliknya. Jika ingin tampak lebih gelap, klik ikon Less 
Contrast atau Less Brightness berkali-kali. 
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Terakhir, Anda dapat mengubah posisi gambar dari kiri ke 
kanan atau sebaliknya. Tekanlah ikon Rotate Left 90  
sehingga gambar akan berputar ke kiri.  

Apabila Anda telah melakukan banyak perubahan pada 
gambar tetapi gambar tersebut malah tampak menjadi sangat 
kacau maka Anda tidak perlu cemas karena gambar tersebut 
masih bisa diselamatkan seperti keadaan semula. Untuk 
melakukannya, tekan ikon Reset yang terdapat di ujung 
kanan toolbar. Sekarang, gambar tersebut berganti ke posisi 
semula. 

 

5  

Teks Menjadi Sebuah Gambar 
 
Mungkinkah tampilan sebuah teks dapat menjadi tampilan 
gambar? Memang kelihatannya tidak mungkin. Tetapi saya 
jamin setelah Anda membaca tip ini, Anda akan tahu bahwa 
program MS Word 2003 dapat mengubah teks menjadi 
sebuah gambar.  

Ada keuntungannya jika teks tersebut berubah menjadi 
gambar. Paling tidak, teks tersebut menjadi lebih terlindung 
karena orang lain tidak bisa mengedit teks-teks itu dengan 
mudah. 

Untuk mengubah teks menjadi gambar, Anda dapat me-
lakukan langkah-langkah berikut. Pertama-tama, pilih dulu 
kalimat atau paragraf yang ingin dijadikan gambar. Setelah, 
itu tekan menu Edit > Copy.  

Kalau sudah, susul dengan menekan menu Edit > Paste 
Special. Di dalam kotak dialog Paste Special, pilihlah Picture. 
Terakhir, tekan tombol OK jika sudah. 
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Gambar 2.6. Memilih Option Picture 

Setelah kembali ke layar kerja Microsoft Word 2003, teks 
yang telah berubah menjadi gambar itu akan langsung 
menempel di dalam dokumen. 

 

6  

Menyembunyikan Gambar 
 
Ketika dokumen Anda telah dipenuhi banyak gambar, 
kadang-kadang gerakan scrollbar vertikal MS Word 2003 
menjadi lebih lamban. Selain itu, dokumen tersebut juga 
akan lebih lama di-loading oleh MS Word 2003 sehingga 
akan lebih baik jika gambar tersebut disembunyikan saja. 
Sebagai penggantinya, di dalam dokumen hanya akan 
muncul kotak bergaris pinggir saja. Tapi pada intinya, 
gambar tersebut hanya sekadar disembunyikan untuk se-
mentara saja. Anda dapat menampilkannya kembali jika 
mau. 

Cara menyembunyikan gambar adalah, klik menu Tools > 
Options. Di dalam kotak dialog Options, klik tab View. 
Carilah option Show dan berilah tanda cek pada Picture 
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placeholders. Pada bagian Print and Web Layout options, 
berilah tanda cek pada options Drawings. 

 

Gambar 2.7. Jendela Options 

Jika sudah selesai, tekan tombol OK dan perhatikan gambar-
gambar yang ada di dalam dokumen Anda. Kini, ia telah 
digantikan oleh kotak bergaris tepi hitam saja. 

 

7  

Mengubah Gambar Berwarna 
Menjadi Hitam Putih 

 
Mungkin, Anda punya foto berwarna yang ingin Anda 
letakkan di dalam skripsi Anda. Tetapi, karena printer yang 
Anda pakai tidaklah berwarna alias hitam putih, maka foto 
berwarna itu tentu tidak bisa dicetak secara manual. 
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Dengan sedih hati, Anda terpaksa harus mengubah foto 
berwarna itu menjadi hitam putih. Dengan menggunakan 
MS Word 2003, Anda dapat mengubah foto warna menjadi 
hitam putih.  

Caranya, klik pada gambar untuk menyeleksinya. Kalau 
sudah, tekan tombol kanan mouse dan pilih Format Picture. 
Setelah itu, tekan tab Picture. Pada bagian Color, pilih 
Grayscale. Dalam sekejap, foto warna Anda akan berubah 
menjadi hitam putih. 

 

8  

Tip Mudah Men-scan Gambar 
 

Ketika Anda akan men-scan gambar, biasanya Anda harus 
membuka program Scan yang telah diinstal bersama-sama 
dengan scanner yang dulu pernah Anda beli. Biasanya, 
program Scan yang khusus untuk men-scan tersebut berada 
di luar lingkungan MS Word 2003 sehingga Anda harus 
bolak-balik dari satu program ke program lain. 

Tapi, kini saya anjurkan Anda tidak melakukan langkah-
langkah di atas lagi karena sebenarnya dalam program MS 
Word 2003, Anda dapat langsung men-scan gambar tanpa 
harus berpindah program.  

Tekniknya seperti ini, klik menu Insert > Picture dan pilihlah 
From Scanner or Camera. 

Kemudian lakukanlah scan seperti layaknya Anda melakukan 
scanning terhadap foto atau dokumen menggunakan pro-
gram yang sering Anda gunakan. 
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Gambar 2.8. Memilih Option From Scanner or Camera 

9  

Menamai Gambar 
 

Ketika Anda membaca sebuah buku yang dipenuhi gambar, 
mungkin buku komputer, politik, atau manajemen, tentu 
Anda akan melihat sebuah teks yang ada di bawah gambar itu 
yang menjelaskan beberapa informasi tentang gambar dan 
urutan gambar tersebut. 

Biasanya, penulis buku mengetikkan teks itu secara manual. 
Tapi, Anda dapat membuatnya dengan tip yang cukup 
sederhana tanpa harus mengetik banyak hal. Tip ini lebih 
hemat energi dan praktis sebab risiko kesalahan bisa sedikit 
mungkin dihilangkan.  

Caranya sebagai berikut. Klik terlebih dulu gambar yang 
ingin diberi nomor urut. Setelah itu, klik menu Insert > 
Reference > Caption. 
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Gambar 2.9. Kotak Dialog Caption 

Sekarang, tekan tombol New Label dan dari kotak dialog 
yang muncul, masukkan kata yang baru, misalnya kata 
‘Gambar’ atau sebangsanya. Kalau sudah, klik OK sebanyak 
dua kali. 

 

Gambar 2.10. Masukkan Label Gambar di sini 

Kini, di bawah gambar muncul teks ’Gambar 1’. Cobalah 
untuk mengklik gambar lainnya dan pilih menu Insert > 
Reference > Caption. Klik OK dan Anda akan membaca teks 
’Gambar 2’ di bawah gambar itu. 

 

10  

Menyisipkan Gambar dalam Teks 
 

Apabila Anda memasukkan sebuah gambar ke dalam do-
kumen, gambar tersebut akan diletakkan di tempat Anda 
meletakkan kursor. Sebenarnya masih ada hal lain yang dapat 
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dilakukan terhadap gambar, seperti meletakkannya di depan 
teks atau juga di belakang teks.  

Untuk melakukan trik tersebut, klik gambar yang ada di 
dokumen Anda dan tekan tombol kanan mouse. Pilih 
Format Picture. 

Pada kotak dialog Format Picture, klik tab Layout dan pada 
bagian Wrapping Style pilih salah satu jenis peletakan gambar 
yang ingin Anda gunakan.  

Contohnya, untuk meletakkan teks di depan gambar, pilihlah 
Behind text. Sedangkan jika ingin gambar berada di depan 
teks, pilihlah In front of text. Lalu akhiri dengan klik OK. 

 

Gambar 2.11. Tab Layout pada Kotak Dialog Format 
Picture 

11  

Membuat Diagram 
 

Semua versi MS Word pada umumnya dapat digunakan 
untuk membuat diagram. Tentu saja, untuk membuat dia-
gram tersebut Anda harus telah memiliki data sebelumnya.  
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Cara untuk membuat diagram adalah sebagai berikut, klik 
menu Insert > Picture > Chart. Kini, Anda akan berhadapan 
dengan sebuah jendela kerja yang baru. Di dalam dokumen 
Anda sendiri secara otomatis akan muncul tempat khusus 
untuk meletakkan grafik atau diagram tersebut.  

Jendela kerja yang akan Anda hadapi sekarang adalah jendela 
kerja Microsoft Graph. Pada bagian Datasheet, masukkanlah 
data yang ingin Anda tampilkan sebagai grafik atau diagram. 

Saat Anda memasukkan data berupa angka atau gambar, 
diagram tersebut secara otomatis akan berubah me-
nyesuaikan dengan data yang Anda masukkan itu. Perubahan 
ini dapat pula terjadi pada bagian Legend grafik itu.  

Selesai Anda membuat tabel, sisipkan grafik atau diagram itu 
ke dalam dokumen dengan cara menutup jendela kerja 
tersebut. Sedangkan untuk mengedit kembali diagram atau 
grafik itu, cukup klik-ganda pada diagram yang ada di dalam 
dokumen Anda. 

 

Gambar 2.12. Diagram atau Grafik dalam Dokumen MS 
Word 2003 
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Secara default, diagram yang digunakan adalah diagram 
batang. Tetapi, jika Anda tidak menyukai model ini, Anda 
dapat menggantinya dengan yang lain. Untuk menggantinya, 
klik-ganda pada diagram tersebut. Setelah itu, klik-kanan dan 
pilihlah Chart Type dan di dalam kotak dialog Chart Type, 
pilih model diagram yang Anda inginkan. 

 

Gambar 2.13. Kotak Dialog Chart Type 

 

 

 

 


