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SRR B A Y A R A == S B A R R R N B A B KA K B Ea ) =T K e
I |G| & [ Th) 2 m | o2 faf 2| 3 |er|d) @ | O\ W O[O0 +| 4 4|4+ | EE| 8 & &«
S|Q @O0 D6 D00 O] D e on| o] o] "

QIO O| @B O] o[ O] 2|4 *| ]| %] 0|5 82440200000 D OO O
Ceel Wl o] e o I s B ) e 7 el e P =1 e e T e e S A Y 2 e =T U L s
S| b =] 2l e|u|e|a| | R|A|e|u|e]=|2]a]|e| 3]s a]e| u|=]|=|v|E|E

O((D-OC;)

To embed all fonts used in the file
select Embed Al Fonts.

To embed only certain fonts.
Ilalke sure that Embed All Fonts,

(= = = T = R =

You want embedded to the Always.

To embed all fonts used in the file
Select Embed All Fonts,

To embed only certain fonts.
Ivlalze sure that Embed All Fonts.

You warnt etmbedded to the Always.

(c)  Change Casel o20d:q): c}ée@o&q§@<§cﬂo&én e[goézcxogsooo
mooo:qo:o%ea:o’]n Utilities Menu ¢ Plug-ins eorrogé Mouse
pointer c>&a3addlon edlaneann Submenu o Change Case...
o3 Click C\E(So']u Change Case Dialog Box eonoeén O(0-09)

this is my computer. lower case
THIS ISMY COMPUTER. UPPER CASE
This Is My Compulter. Title Case

This is my computer.

Sentence case

tHIS IS MY COMPUTER. tOGGLE cASE
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% lower caze
- 7 Title Caze e
= Sentence caze. Apply |
" WOGGLE cASE Hestare |
(o)  Drop capi PageMaker Document 8Eomdacl 0335ep:0p¢ Drop
L L L (o)

Dirop cap

Size: Enes

C c ocC "] C o C C E QOC ° C °
Cap (I)@ODC:&CO OD@II O@§%02 C S’QOC\DO(D’)C\)SQJ’)S‘JBOD(DS’BOD‘:
2 0 L (] ° L [¢] L

o[ [g§ 000220305 Bearpee§dl poes er35c10meneEie
4 9¢ (¢} PResION 2 L °3
%0 mcfg:crogeazor]u Utilities Menue Plug-ins eoTogé Mouse
pointer o>éca¢lon el awneonn Submenu o Drop cap... o3
H C H C o C
Click co&cli Drop cap Dialog Box edl'conepdid(n-06)cE: Box
éﬁ Size: 038 %or]o%%(rgooéo']n Q@%s@oz@é 3 Ex]o%oaéu oféez?oo%
Apply 3 CliCchgor]u ea:ooo:eoaomcx}:ooé 3Iines§§é%ewo
s'aad‘sgam: wog@:ogo:eéu e@cﬁmfz)gogé Drop cap oocc)ooé:
Q 00C 00C C (o] C
oScloo Next 385G Apply o3850l Next s& Apply o3 sodbq)
ocC ocC ° C C C (o
.§oog'3:o']u 02Q3QRTIRANRNC Drop cap ep:oog@: @@og):e@n
C (o] cocC

Drop cap o3 [g§[glo5c3clo> Remove o3 853 Apply 3006860

L d

| Xl
Go to paragraph
Apply Remove | Prey | Hest | [ |

Pagelldoerinehidee frrebuit-in trackethet decrepes or
iteraaes the epacd bietareet charaobere o wating deghace,
ﬁ'nm?m'}r looseto ?:r}rTi.Eht

Trackig in PagelLabar depende on fontand podnt eine;
eachiirack isa cdle chom of vahes that moelates the =2re
oFaforterith aapie efic aronand ofchimnge in lebe s apacing,
Vi oo evren edittra b oz apecific fonde ot specific sfres,

Toueat sppikr abrackto oorran e of Lozt Becasartiacking
inFagehlabiaris o charactaelael atebnate, 1me can apply
otd trekito prenps af bed, wod then eppdy @ different
trackto text that'e i tha sne font, eren the pane aizs,
eoenewhees alee,

ahoet includa e five bnaidt- i 11a ke thet decreas s
Ot oy pass Lhe apace betere e cheractera to sasrig
dagraae, from VargLo oee o Veey Tight.

Tacﬁﬂg i Pagallaker depetide on font and point
eiza; sach track ie 4 collaction af veluse thet
comelstes the Sve of 2 fmi Wﬂhaspzciﬁc am munt
of chage mleHter cparmg Y'ow can even e dit tracks for
:Ful:iﬁ: Forts o :Pm:iﬁl: sIEs.

‘- .?'-:-ucm apply attackio ange renge of text Bepagae
trackitng in Pageddaker ia o charactes-lerel
aittitugte, you oo nppbr ane backto 4 range of

1exl, and then appdir o differet feack to texd that e in the
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(s0) Merge Recordsi PageMaker Document 3¢oods§ oogab§r03¢
Data & (fcooo):%gg Record qp.,eo']c,oogeoog o @o%o’]oaén Merge
Records co6q$ Data source 3EQgscdd] aopdi Data source 3Eaopd
*.CSV or *. TXT 3Esadpseon: [goqepd[ydoopdn Merge Record

c_C C cr] oc. . Q C Q
C\B()el§8’20800 6320000 S’BO?C,C\QOGSO’JCGFQQ—
c 9

(o)  Datasource 3¢mda0s03:qs Notepad Software cr‘§ G
csmonol Data qo:%(ﬁooé@: Address.txt soeé@é &:0l-
Name, City, Phone
U Ko Ko, Yangon, 111111
U Mya, Mandalay, 222222
U Hla, Taungyi, 333333
Daw Aye Aye, Pyay, 444444
() Page Maker§coéao3 gcsliWindow Menu ¢ Plug-in
Palettes (7% Click C\B(C)@: colameom Submenue Show
Data Merge Palette o3 Click coSali ¢(0-00)
| window

Arrange Icons

Tile

Cascade

Hide Tools

Show Conkraol Palette o~

Show Colors ] (3(07'0’2)
Shove Styles ~B

Show Lavers g

Showe Masker Pages Sh-a

Shaow Hyperlinks #4)

Flug-in Palettes Shiow Library:
Shiowe Scripks

2 DO LIME e LMY TNT S LMY DO e \PFHOTES. prod
v Lintitled-1

Show Data Merge Palette
Show Template Palette
Show Picture Palette

(p)  Data Merge Palette adloonepdi g&:§ Right arrorw
Click 0300% colconeam list o Select Data Source...
Click C\380']||<°3(®-0®)

Q
o
L
Q
o
L
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Select Data Source. ..

o(o-o0)
Ereview Recards

Merge Recards, .,
5w To Recard, .,

(5)  Select Data Source Dialog Box el conepdid(e-op) 6
Box 035 mc?§(o)saq@$o%:oo’3:eooo Address.txt (755

C Qo Qo OC o H C
603,qepdl 92330103 3EegeG: Open o3 Click codaln

Srient Dl S R 1
Lodk irc IE by Documens d L ﬂi- Ew

ﬁ My Pctiras
=r-iras

gl n-op)

Fila narma: I.-!,ddm ﬂ Opan
|

Filez ol bpe | Commapainitad (~.ce.% 181

(9)  Data Merge Palette cp¢ File Name (Address.txt) s¢saon
Name, City, Phone ooaé@cf: Data gaeéqpm% eogosleén

(o~ o)
Mouse Click
|
Addreg At r
/ Fs
T Ng}é/ | E=Mame==
/ = City== °
T Liy < Phones:= (-L)(G)_\.JO)
i Phone____|
hd
TEIEN [ 1] [T Preview
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®)

Iilities

Merge [giopdcSeaxs PageMaker Document 3¢ gEqopbi
poeo Letter.pmd Ezo&roe%ocf:o']n ogodsoel Data el cBean
esepa Cursor gdli cdegood> Data Merge Palette o
Name orS: Click C\%&ﬂn Document cﬁ@oel](ﬁ%oogé
<<Name>> cclcnepdi Enter§Gazo0s6) City, Phone
o%Lo% Click 0860qu gaooa%o’]CL) seo%& Data (g)?eofrmoeén
Begood Utilities Menu ¢ Plug-insedl'o3é Mouse
pointer o>éado3clon edlaoneon Submenu o Merge
Records... &3 Click cobalid(e-_jo) Merge Records Dialog

Box GoT@D@éllQ(@—JJ) OK (7% Click C\g&ﬂn

Add coriine...

Balance Columns. ..

Find. .. - F

!n Build Booklet. ..
Fimd Mexk 5 .

Bullets and numbeting. ..

Change... “=H
spelling 21 Change Case... .

- Create Color Library... 9(®‘J3)
Boak. .. Drop cap...
Index Entry... ™% EPS Fank Scanner...
Show Indesx. .. Global Link Options. ..

Create Index. ..
Create TOC,,,

Garid Manager...
Kevline. ..
Merge Recards...
x|
— Record Ranae
= All Becards

= Current Record

i~ Ranges: I'I -4

E nter record numbers and/or ranges
zeparated by commas. For example 1.4,6-11

— Laypout Options

CL)(G)—JJ) Fecords per page: IDne record per page ;l
Cal. Gutter:l— inches

Raow Gutter: I— inches

I Remowve Blank Lines far Ermpty Fields

[ Embed Images [increazes file size]

[v Start Mew Publication &fter IED Fages

ak. I Cancel
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(6)) Record (9):%100@6: Record sraesls'aogcﬁsfacoe& O’J@JO’S?’)
(6)qodso0p¢ Data gpeeclCsays(@e Untitled-1 sp0pSgc
ocC C C C C c o¢C QCc O C C
3E06m63[gdooepdi GE:8E sz B&3dlm 30500
c01§) B3&:qepdI

Running Headers & Footersi >6z00506050p5:§e000 00605
sogmopc Header s¢ Footer copde$gdcloogbi 3Eomdagcdli
oeorsn§ Text Block o3 Select C\B(C)ejea:o']n Besoad Header
Footer gpzoopdqs Utilities Menu o Plug-ins @@ Submenu o
Running Headers & Footers... 3Click codalid(e- jp) Running
Headers & Footers Dialog Box eol'conepdid(e- o)

Lkilities
acd contde,.
Find e Balance Columns.. .
?n - Build Booklet. ..
Find Mexk e :
Bullets and numbering. ..
Change. .. s
S . Change Case. ..
e Create Colar Library. ..
o Book... Drop cap...
Q(Q_J’\)) Index Entry... ™ EPS Fork Scannet. ..
Show Indesx... Global Link Options. ..
Create Index, .. Grid Managet. ..
Create TOC,,, Kevline. .,

Merge Records, ..
Publication Corwverter. ..
CuickTime Media. .,

Define Colors, ..

Running Headers & Fookers, .,

|~
-0

(o)  Header ooésﬁooogog Place egaoogg]m
oogesnel Headeresepal Drag codq Kool
() ©§05q$ Content:en Text Boxogé Cursorgjq)

m%ogooéo']||eoe’)“PageMaker?.O”%o%o']nCL)(m—Jg)

Content: -

12t "Wiord of First Para [P RIEERE SR l] :I
6(‘”‘\)3) 1zt Waord of Last Fara
t Entire First Para hd
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&(o-J9)
Running Headers & Fookers
ID::u:ument Masterj |1 Place LI
= Cancel |
|_n_|</’
Prewvigw. .. |

Search Style

3.003
II !I - vl 0.503

H1 06

Content Style

— Caontent;

Define...

1zt wiord af First Para P
Tt "Word of Last Para
Entire First Para

Pagekd aker 7.0
=i

sdd> |

Content syntax OF

IBDd_',' bet
Apply Ta
Al Pages in Stany

™ Range: I

[

[T Exclude First Page

®oqlo%§owo:cf3:ogéeoTG®q$ Apply To Box 035

All Pages in Story o%ea:or]n oaor%?o%ﬁ eoTeocfEC\}Jg:

.9 e, c c ¢ Cc9C S
Range: o?ea,[&e]o elllleal-plenieal leat=/[oslIople sTebllox

q@éll

Style a>0de05c3Slon Content Style o3¢ Body Text,

Caption, Hanging indent, Headline, Normal
cc C C C o
®OD@[§(;ODO’)QJ§O’)GOSS]@@II(B(®-J@)

&(o- J6)

Content Style

=

IE-::-:I_I,I beut

Caption
Hanaing indent
Headline
MHormal
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(3) Footer ooéc{%o']m gaooo%oké:sao%&ag@eeooéq%
G5 NaogSi

(@) wo%go%qcﬁ@p:@égcﬁl ea:qcfa@:o’]m OK (703 Click
C\foﬂu “PageMaker 7.0” oooo&:oaé meJo%‘?ogngl
Header G§qoogéeonoeéll

Show / Hide ToolBaru ToolBar so: seofz:@q;%a%so@o’]m

6l cone0:§ESloopdi :a0dtecdClmenpadconigfgdsloopdi

Utilities MenuePlug-insedl'op¢é mouse pointer ooéadod

Jli edl'coneaxs Submenu o Show/Hide ToolBar o3 Click

C\BBO']MCL)(Q— JQ) ToolBar eeo’Tor]meoneé@o%@m ToolBar

GOTG?OWO’J GOJ’J(TSOg’JS@é@OSOr]ODéII

| Utilities
Addconidine...
Fird o Balance Columnns. ..
?n Euild Bocklet. ..
Fimd ek 5 .
Bullets and numbering. ..
Zhange. .. “H
=l . Change Case...
6(07 ) ... Create Color Library, ..,
L J? Boak. .. Drop cap. ..
Index Entry.,.. ¥ EF3 Fank Scanner,..
Show Index. .. Global Link Options. ..
Create Index. .. Grid Manager. ..
Create TOC, ., kevline. ..

Merge Records. ..

Publication Comverter. ..
QuickTime Media. ..

Running Headers & Fookers, .,

Define Colars, ..

Save For Service Provider, .,
ShowHide ToolBar

Word Counteri Character, Word, Sentence, Paragraph,
Text object s¢ Stories 00050361 926q92030503 ol |g

Go:sl;%@ocacﬂwén Word count cofm%eoao 88@89(73 @8 ']n
L L L L L O¢°

Utilities Menu ¢ Plug-ins &1 Submenu o3¢ Word

o
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Counter o3 Click co6clio(o- jo) Word Counter Dialog
Box eo’Tcooeén 98:088 soeqseogo%@p:t% ewT@ooo:a)éo%
o C o _ C C C CcC O O f]m
eogoeﬂslegn&)(m J@) DIGOIED OIOGI§IFVROIVAVO
g&meﬂ(ﬁﬁocﬁea:@: Word Counter (703 Click C\g&ﬂu gas%or]
GSSQJOSCD’J:GCD’J o)o@J(ﬁ?ocﬁ Character, Word o)oaé

C (o] C
S?GS]S?U(;(D@J’D:O? G@T@GO:Q@II

LItilities
Aed ot
Fird . Balance Columnns...
i, ..
i Build Booklet. .,
Fimd Mext o5 .
Bullets and nurmbering. ..
Change. .. “H
ol " Change Case. ..
PEing. Creake Color Librarsy.. .
Boak, .. Drop cap. ..
Index Enfkrw... ™ EP3 Fonk Scanner ...
C)(G)—JG)) Show Index... Gll?lbal Link Cpkions...
t Create Index., .. G@rid Manager. ..
Create TOC, .. kevline. ..

Merge Records. .,

Publication Converter. ..
CuickTime Media. ..

Running Headers & Footers., .,

Define Calars. ..

Save For Service Provider ..,
ShowHide ToolBar

Word Counker

oo Je)
zl
Characters: G754 T et objects: 43
Wiords: 230 Stories: 21

Sentences: a7



| Contents

Adobe PageMaker 7.0 o J6 nmR§

Book

ool PageMaker Document Publications 3Eep:sao: BoOK 02629(9d 0opd:
col&od SECloopdi poeooalyé  3E(0)3Esa: Book cwde$ Utilities Menu o
Book o3 Click coddlid(e-po) Book Publication List Dialog Box eclaosegbi
(9-p0) 8Eqp:§oops Folder(c:\my file) Bycali Files/Directories: esaadope
Sgpieclanegdi g&(ofésm:ea:ej Book list 90038::1% Insert Button o3 Click

G0 rCe

06§30l Begncd vedEons) m$dEeiamt 5285205903 eogodg0lodep:
208 GOl ey PCQOY) OPCREsaE RI20PCE DOQO2§0$0I00€02

DO oo@ogo:eo:eﬁ Auto renumbering: ogcc: Next page o%ea:qeén
B:oqé OK o3 Click coddli eclavnears Adobe PageMaker 7.0 Dialog Box
088 Yes cﬁ%&or]uq)(@—gJ) s@a%o’]fgé(rg)ggéoaé :)8:[%3:8%@§eé @o%eoo%cué: Book
Publication ooo%§>99@ogeor]8:®8agozeé@o%oaém[§5 mqo%@o%or]o%q’):wémé:
Book list gl &}59@89@@@9@0’%& ooocasoo%ooé: oogogo:eé@ogor]oaéu

o

a Ol®»-D0 %
Likilities L( v ) 9(“'?3)
Flug-ins 2 Book Publication List

x|
Firid, . s F Path:  c:my file

Fimd|[Wext e

fi o dovw

Cancel
Zhange. ., “H
Soelling. .. 2 Filez/Directonies: Boak: list:
PFYHOTEY.prnd - Inzert | FYMOTEY . prod
Eoolk. .. PYMOTEZ prnd PYMOTEZ prnd
FYHOTE 3. prnd B FYMOTE 3. prnd
F7NOTE 4 prd ﬂl F7MOTE 4 prd
PYHMOTES. prnd PYMOTES. prnd
P7NOTEE.prod wl PFHOTEE.pmd

Auta renurmbering: € Mone " Next odd page
f* hewtpage  Mesteven page

&(o-p )

Adobe PageMaker 7.0 |

Auto renumbering is selected.
Do o wank bo update the page numbers of all the publications in the book list now?
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Create TOC
oopI  PageMaker 8350’)03?038 o030 (Table of content-TOC) o3:[go:§o59

03> ooéog&%&ﬂoaéu 9030 © fq%s’aogcg PageMaker 835%(5@088 Style
c  C Qo C CC'] CStIe c  C Cc OCO C .8, C"'C
2005605q) §05qep5[goclaopdi Stylecocdecdepaat GE§ eogodgnardiiadicptdlod
C "]Co C Y ']Co C "]C° C ocC ’]Co C oOCN "]C° c _¢ o C
cpo0p) eslSiod[oR e3lCi0dl :0eslCi0d 0333651800 00383651E058E 0230

026) 05e0560:(G: §odeepdi A3ea0 E2BIEIEM§0§0%:8EeRS [gocladi

28l 3 G AP RS (O°§P0§OxCeoR) 2

C C C C ocC C C
()  esl&05[F920905 6920056l903¢E:0066500E -
(o)  Style ddeod9s Window Menu ¢ Show Styles o3 Click
C C °
cwbali Styles palette eol'conepdi &(0-pp)

W
| Styles r

Eody tent

Caption

Hanging indent

CL)(G)_??) Headline

Hormal
Subhead 1

Subhead 2

(&[T ]/

()  Styles palette 035 c‘é?%s’ao:@é [No Style] @5e§eén
Headline o3eggoli Right arrow ¥ o3 Click wSeane3]
e6lconeoon Submenue Style Options...cr%ea:o’]né’g(m-gg)

Styles ™, » Mew Skyle. .,
[Mo style] Delete "Headline"
LL)(G)—Q(; Fiody test Duplicate "Headline"
Caption Skyle Options. ..

Hanging indent Add HTML Stvles
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(®)

B3| Style Option Dialog Box eol'conepdid(e-p9)

o(0-99)

Character Specifications

Fart:
Size:
Leadi
Hariz
Colar:
Tirt:

Type

WETE
Bazed om: INn:u shyle j
Mext style: ISame ghyle j

next: Same style + face: Times Mew
Foman + bold + size: 18 + leading: auto Para...
+ flugh left + incl TOC

Cancel

FEELEE,

Tabs...

caléiod[oisan Style acdocdqs  Char. | Button o3
Click c\360']u Character Specifications Dialog Box
aclamepdi O(n-p6) e Font:, Size:, Leading: Type
Style: <D00é0cé(7% C\Ogoacf’eooogcfo%eo:@: OK &3 Click C\ES(S]II
pooomes(g¢ Font: Times New Romani Size: 18
Leading: Autor Type Style: Bold coo5¢c5a0o:dloogli

OF.

18 ¥ | pointz  Positio; Im Cancel
hig: Auto *| pointz Casze: Im
scale; |Momal = | & Track: m
IBIack j Line end: Im

Optiong...

e

I'IEIEI vI'Z
stule: [ Mormal [ ltalic [~ Feverse
v Bold [ Underline [ Strikethm

Character Specificationoooseodaodep: 200560530l
Style Options Dialog box§ | Paw. | Button 03§54l
Paragraph Specifications Dialog Box eclcwsepdid(e-
00) 95:9 Alignment:ogé Centercféea:@: OKa3 %66]"



| Contents

Adobe PageMaker 7.0 o Je nmR§

Paragraph Specifications El
Indents: Paragraph space:

Left ||:| inches Befare ||:| inches Cancel |
First IEI inches After IEI inches
Rules... |

5 6 - Right II:I inches
CL)(G) ??) Spacing... |

Alignment: | Center j Dictionany: ILIS Englizh j
Optiomns:
Right ]
[ Keep .JLEtify_ | ™ Keep with nest IIZI lines
[~ ColuntEoree justi [T widow contral ID lines

" Page break before [T Orphan control ID lines

¥ Include in table of contents

(6)  eslC:ofoRrsSood005) 5ac3§ean Style avcdoadaodep:

ea:qu%ooo%go%@:o’]m OK o3 Click codaln
(3)  eslEod[Brean: Styleadcdeos(Biclon eaﬂ&@és@ogng Style 205e05

9§ €92205Clm03E0006a00Ed]-

(o)  Styles palette eol'coqs Window Menu o Show Styles
o3 Click codali

()  Styles palette o3¢ Subheadl o3egesli Right arrow [» o3
Clickapbean=sl edlaneas SubmenueStyle Options...

cﬁea:or]nc}(a—gm)

Styles ™, » Mew Stvle, .,
Captioh =~  Delete "subhead 1"

Hanging indent Duplicate "subhead 1

(0-)-’\307) Headline Skyle Options. ..

~Co

Mormal Add HTML Styles

Subhead 1 Impork Skyles. ..
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(p)  DB=esl Style Option Dialog Box eol'conepdi esl:odsa:
Style a>05¢059$ Char.. Button o3 Click codoli Character
Specifications Dialog Box eol'conepdi 6&:e Font:, Size:,
Leading: Type Style: 020050303 cdoocBaocsecdeos: OK
o3 Click cobali poensaes[gé Font: Times New Roman
Size: 161 Leading: Autor Type Style: Bold co05¢05000:
(.)r]CDéII

(9) Gzﬂé:@és’aogcﬁ sfao%(sﬁeooo Style oao%go%qo%qo: Ga:@JOS
wo%go%@:o’]m OK (7% Click cxzcc)o']n

22063|C:0590305 Styles palette o3¢ Subhead2 e

Font:, Size:, Leading: Type Style D0PORNR 303005

Goo@. OK o? Click cxzoo']n

8’2(\)’)30{ ®’)(?I_)8G8’]8§®§I 0)’)(?5%691830)@ ?Cf? O)’DO%OS ®2Dé093°890308

Q0 C c C C ’] C C C ’]
S”BC\)GlGOD’D Style ODO’)@O’JGI:? S2CONMD0IFODCICO063DCOI
L1 ] L

C

f]C C f]C C ']C C ocC Lf]C OC N "]C [
G C"Oe@"l G C°®8I 8’9069 C"O)el 0)’)08@9 (033 tDeI 0003969 CStDB
L O

o ’]II QODG D
2O 2 :?,-

[e]

§¢ 035 oos’acnm Style Qpe9a3:0d: ODO’)QUS[(_Q_] :0lo> PageMaker

d

N

LLOCUgC Q)(YJGGPO’) @OGO&}%C\)OG&)’JCS}@@@%O’]Q}

(o)  PageMaker 3éa3gccli Styles Palette 030 conicli ode§o05
LO ° LO°

L

[¢] C
GUB’)(TJOr]UBU.B C\EOGSO’)C(.){]—

(o)  Style w05¢05c3ca eé]&oé@:o%ea:or]n Style Palette ¢

d

Headlinecﬁegzo{]u{e(m—g@) or%s'aar] ear]&o)é@:oaé 38

C C N C C C ocC C C
200000096200 Style ODO’J@O’JQJ(T)S’BU)CSG@’JCSOD’JS@[BII
1 ° 1 L (¢]

o Styles ™ ﬂ
(-L)(G)_?@) [Ma style]
Color manangement Body bext
Datarining howto usea CHS Caption
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(00-0) Save As Dialog Box eol'aonepdid(oo- j) File name: ogf: 3Es205
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| File
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Save as twpe: | Publication j Cancel |

Publication
T emplate
& Mo addi & copy in 6.5 format
™ Files required for remate printing

&l linked files

Copy:
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1. Choose File > Print.
2. 1If you’reI printian onsa PoséScrtipt
°, rinter, ect a PostScript Printer
9(00“@) n n Besc?ipti%% (PPD) file frompthe PPD
pop-up menu that matches the printer
t .
gl.plgo one of the following:
T

1. Choose File > Print.
2. If you're printing on a PostScript
printer, select a PostScript Printer
Description (PPD) file from the PPD pop-
up menu that matches the printer type.
3. Do one of the following:

1 .
Choose File > Print.
2. If you're printing on a PostScript
printer, select a PostScript Printer
Description (PPD) file from the PPD pop-
up menu that matches the printer type.
3. Do one of the following:
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PageMaker Shortcuts
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A. Pointer tool (F9)

B. Rotating tool (1 +F2)

C. Line tool ({1+F3)

D. Rectangle tool ({1 +F4)

E. Ellipse tool ({}+F5)

F. Polygon tool (1I'+F6)

G. Hand tool, Constrained-hand tool ({I+Alt+drag+ left mouse button)
H. Text tool ({I+Alt+F1)

. Cropping tool ({I +Alt+F2)

J. Constrained-line tool (1 +Alt+F3)
K. Rectangle frame tool (I +Alt+F4)
L. Ellipse Frame tool ({I +Alt+F5)
M. Polygon Frame tool (I +Alt+F6)
N. Zoom tool ({F +Alt+F7)
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Laying Out a Publication

Result Action

Open a copy of a publication or the original 1+ File > Recent

of a template Publications

Revert to last mini-save 1+ File > Revert

Save all open pubs (Save becomes Save All) 1+ File > Save All

Close all open pubs (Close becomes Close All) 1+ File > Close All

Insert one page Ctrl + Alt +0+ G

Auto/manual text flow (toggle) Ctrl + flow text

Semi-automatic text flow 1+ flow text

Proportional resize(for graphics or grouped objects) {r+ drag any handle

graphics proportionately to printer resolution) Ctrl +1+ drag handle

Defer text redraw while adjusting text wrap Hold spacebar

Select multiple elements 1r-click each element

Select element behind others Ctrl-click (each click
selects next element back)

Select multiple elements behind others Ctrl +1r-click

Mask and Group 1{t+ Element > Mask

and Group

Unmask and Ungroup 1t+ Element > Unmask

and Ungroup
Constrain move vertically or horizontally {r+ drag element
Paste items in the same position as the original (power paste) Ctrl + Alt + V

Edit OLE object Double-click object
Edit original Alt+double-click object
Nudge selected object Press arrow keys

Nudge selected object by ten times the amount in Preferences 1+ press arrow keys
Rotate from center of bounding box or text block Ctrl + Rotating tool

Constrain rotation to 45° increments {r+ Rotating tool

- Shift
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Viewing a Publication

RESULT ACTION
Set all pages to same view Alt + View > any view
Change page to fit in window Ctrl + 0or -click page icon or

Alt + double-click zoom tool
100% view Double-click zoom tool or Ctrl + 1
100%/Fit in window (toggle) Ctrl + Alt + right-click page
100%/200% (toggle) Ctrl + Alt + + right-click page
Edit story or text frame Triple-click text object with pointer tool
Redraw current page Use shortcut for current view

Redraw page in high resolution Ctrl + 00+ F12

Cycle through pages 1+ Layout > Go to Page (click mouse or
press any key to stop)

Go to next page Page Down

Go to previous page Page Up

Go forward to previous
page selected Ctrl + Page Down

Go back to previous page selected  Ctrl + Page Up
Zoom in / zoom out Ctrl + plus key (+) / Ctrl + minus key (-)

View hyperlinks F10
Printing a Publication
RESULT ACTION

Save print settings without printing -click Done

Save print settings as a printer style Ctrl-click Style
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Typographical Controls

RESULT ACTION
Increase one point size (Layout view only) Ctrl + v+ >
Increase to next standard menu size(Layout view only) Ctrl + Alt + >
Decrease one point size (Layout view only) Ctrl + 0+ <
Decrease to next standard menu size (Layout view only) Ctrl + Alt + <
All caps (toggle on and off) Ctrl+ 1+ K
Subscript (toggle on and off) Ctrl +\
Superscript (toggle on and off) Ctrl + T+ \
Kern apart .01 em (Layout view only) Alt + Right Arrow
Kern together .01 em (Layout view only) Alt + Left Arrow
Kern apart .04 em (Layout view only) Ctrl + Alt + Right Arrow
Kern together .04 em (Layout view only) Ctrl + Alt + Left Arrow
Clear manual kerning (Layout view only) Ctrl+ Alt+ K
Indexing
RESULT ACTION
Show index for active publication Ctrl + Utilities > Show Index
Create index entry Select text, then Ctrl +Y
Create fast index entry Select text, then Ctrl + t+Y
Create proper name index entry Select first and last name,

then Ctrl + Alt +Y
Remove all index entries Ctrl + Alt + {++ Remove

(in Show Index dialog box)
Remove all cross-references Ctrl + {t+ Remove

(in Show Index dialog box)
Remove all page-referenced entries Ctrl + Alt + Remove

(in Show Index dialog box)
Remove entries since last accept Alt + Add X-refs

(in Show Index dialog box)
Restore entries removed since last accept Alt + Remove

(in Show Index dialog box)
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Text Editing
RESULT
Select word
Select paragraph
Up one line
Down one line
To beginning of line
To end of line
Left one character
Right one character
Left one word
Right one word
Up one paragraph
Down one paragraph
With I-beam in text, select words to the left
With I-beam in text, select words to the right
With I-beam in text, select a range of text
Drag left-indent marker only

Reset Character Attributes to any

Reset Para Attributes to any

Reset Character and Para Attributes to any
Attributes(in Find and Change dialog boxes)

Move to beginning of story

Move to end of story

Up one screen

Down one screen

Close current story window only
Close all open stories in current pub

Cascade all open stories in all open pubs

Tile all open stories in all open pubs

ACTION
Double-click with 1-beam
Triple-click with I-beam
Up Arrow
Down Arrow
Home
End
Left Arrow
Right Arrow
Ctrl + Left Arrow
Ctrl + Right Arrow
Ctrl + Up Arrow
Ctrl + Down Arrow
Ctrl + 1+ Left Arrow
Ctrl + 0+ Right Arrow
{r+ press a shortcut (such as End)

1+ drag indent (in Indents/Tabs
dialog box)

Alt-click Char Attributes (in Find and
Change dialog boxes)

Alt-click Para Attributes (in Find and
Change dialog boxes)

1+ Alt-click Char Attributes or Para

Ctrl + Page up (in Story Editor)
Ctrl + Page down (in Story Editor)
Page up (in Story Editor)

Page down (in Story Editor)

Ctrl + W (in Story Editor)

1r+ Story > Close Story (in Story
Editor)

{r+ Window > Cascade (in Story
Editor)

1+ Window > Tile (in Story Editor)
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() 838390305(8<f:sl$ File Menu ¢ New o3 Click coScli Document
Setup Dialog Box eo’Tm’;eéugcc::ogcczesaocﬁor]sao%&@éogdc)@:
OK a386¢l-
Page size: A4
Orientation: Tall
Option: Double-sided Marking [go5¢]

Numberof pages: 1
Start page#: 1

Margins- Left: -1.5 Right: - 0.5
Top: -1 Bottom: - 1
Compose to printer: - HP LaserJet 1100
(3) esl&0590905 carecEREYA} veBig> Peepdt ToolBOX ¢
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(2)

GErommeepEoopdas ea:o’]n Windows Menu ¢ Show Colors
o3 Click co&ali eol'aoneann Colors Palette ¢ Black (7%@8;:0']”
GQ']E:;oé@oooo:sgogo% ToolBox ¢ Text Tool orogeaz@: §odepd
esepa¢ Cursor sl Control Palette op¢ -Win---Yangon Font
§¢ Size-40 2050050l Besnad “SEeeqrBionpda)d(g)d” oo
§odcli
ptev etz oY em:eoooéogéeofra%agoi@: OO0l r000:90: Text
Tool S3sead(g[Ge egcl Control Palette o Reverse o Click
w&ali
02000286 emzemoéc@o%ma:mm@mé:qe@q%ng)eaooé@:o']oo
926|821 005 B3eozdli
o238em:§05e$ ToolBox ¢ Text Tool (?eea:@: POQOIEOEN TDASNOD
Margin o3¢ Cursor gjoli -Win---Researcher Font s¢ Size-17
Ga:o{]n sogeg(o)oowoseﬂozo%%cﬁ&n Enter %fxﬂn me):C;(J)l(g)(c;)
o%o%cué: Enter %(C)ej aocﬁ%o%o’]n
0535¢p:§dGeclon 9820%038 Bullet gp:copiqé mggg(g)?(r%eazo I
Utilities Menu ¢ Plug-ins scTo3¢ Mouse pointer
mEaSadeansesl Submenu edlamepSi GE:e Bullets and
numbering...o3 Click codoli Bullets and numbering Dialog Box
e6lconepdi
Bullet qo:ea:q% Edit Button o3 Click co6cln Edit Bullet Dialog
Box o>dac0bedl amepbi o Font ogf: Wingding2 Siz 085
15 (ﬁ@g:(ﬂﬂO%@@O% collaomeom eoogo%cj» %k o%ea:@: OK o%
Click coddl
Bullets and numbering Dialog Box [g§edlaooepdi OK o3 Click
w&ali
Bullet gp:oopdGeegocd Indent o3¢ o)oggscseﬂazsfao:ea:or]n Type
Menu o Indents/Tabs o3 Click coScli (3e0r05) Shortcut Key
Ctrl+l 6385l Indents/Tabs edl'conepdi
Mouse pointer o3 Left Indent ecl'oaéoncq) Shift Key 0385agj05
|

oooeme@o&so@og Drag C\gﬁejaguao']n o%e‘?oog OK ov%%f)or]l
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Palette o3¢ Font - Time New Roman 1 size - 13 aocb¢05¢li
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Copy oxq$ Pointer Tool i3%005sg)q) Text Frame o3eg:(g: Edit
Menue Copya3 Click codali Edit Menu ¢ Pastea3 Click co5dl
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